[SOLVED] Trouble with phc-intel on Gentoo

If you have trouble with PHC you can ask and hope for help here.
Post Reply
Posts: 2
Joined: Tue 11. Mar 2014, 16:58

[SOLVED] Trouble with phc-intel on Gentoo

Post by Wintershade » Tue 11. Mar 2014, 17:09

Hi everyone, an occasional lurker here. I've decided to give phc-intel a go once more and I'm having trouble loading the module - sometimes. Sometimes it loads successfully, other times it doesn't. It seems like around 30%-70% (in favour of not loading), but I may be pessimistic on that remark (it might be simply 50%-50%).

I'm using Gentoo Linux with OpenRC, kernel 3.12.5-ck. I've successfully compiled and installed phc-intel through portage. Afterwards, I've put

Code: Select all

echo "16 6 0" > /sys/devices/system/cpu/cpu0/cpufreq/phc_vids
echo "16 6 0" > /sys/devices/system/cpu/cpu1/cpufreq/phc_vids
in my /etc/profile, in order to load these VIDs on startup.

I've put phc-intel as a module to load in /etc/conf.d/modules, as well as blacklisted acpi_cpufreq and cpufreq_stats via my /etc/modprobe.d/blacklist.conf.

However, it seems that acpi_cpufreq still sometimes loads during startup. What bothers me is that it sometimes loads, and sometimes it loads phc-intel properly, and I can see it using my modified VIDs and voltages (I can see that through both the phctool, and by monitoring my CPU temperature).

If anyone could help me shed some light on this, or tell me what I'm doing wrong, I would be most grateful.

SOLVED: The problem is gone, now that I have compiled the 3.10-lqx kernel. I am not sure whether the problem was in the kernel version (is 3.12 too new?), the patchset (although LQX kernel contains the CK patches), or my kernel configuration. Most likely the configuration.
Last edited by Wintershade on Fri 28. Mar 2014, 14:55, edited 1 time in total.

Posts: 2
Joined: Tue 11. Mar 2014, 16:58

Re: Trouble with phc-intel on Gentoo - sometimes doesn't loa

Post by Wintershade » Sun 16. Mar 2014, 20:06

A short update:

I've tried recompiling the kernel, without the acpi_cpufreq module. I've also tried adding

Code: Select all

as a kernel boot parameter into my GRUB configuration.

Neither worked, phc-intel still sometimes loads, and sometimes doesn't. What I've discovered is that the module itself sometimes cannot load, for some reason (it seems like it's not the conflict between modules that are already loaded). Anyone got any idea about this? TIA

EDIT: I've checked the wiki again, and here is the relevant info that I should have posted...
1. What Linux distribution you are using.
I'm using Gentoo Linux (mostly stable, with a few unstable packages), currently with the 3.12.5-ck kernel.
2. The content of /proc/cpuinfo
That's a big one, I've pasted it here.
3. The output of “dmesg”
That's a huge one, I've pasted it here.
4. The output of “lsmod”
Another huge one, I've pasted it here.
5. The output of /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver

Code: Select all

$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver
6. The output of /sys/devices/system/cpu/cpu0/cpufreq/phc_version

Code: Select all

$ cat /sys/devices/system/cpu/cpu0/cpufreq/phc_version
cat: /sys/devices/system/cpu/cpu0/cpufreq/phc_version: No such file or directory

Post Reply